Cadfil Help Contents Page

Cadfil - Advanced filament Winding software for program generation for all type of filament winding machine.

Tutorial 1: - Quick CAD – Vessel With End Caps

In this example we create a winding program for a typical gas bottle such as compressed natural gas (CNG) cylinder. The Winding consists of:

2 layers at Hoop (circumferential winding on the cylinder) V120H01

A Transition (joining path hoop to helical) V120T02

1 layer Helical +/- 15 degrees V120P03

This tutorial is not meant to represent an actual complete design, is intended to illustrate some of the methods and tools available in Cadfil-Lite+. This Tutorial was created with Cadfil 7.50, other versions may have small differences.

This example used Vessel With End-caps from QuickCAD Menu. A mandrel geometry is shown to the right, this is a cylinder with two ‘torispherical’ end caps each comprised of two radii. The left Hand (LH) and right hand (RH) end caps can be different but are the same for this example. A a very good torispherical approximation to other shapes such as the isotensoid shape can usually be made. Elliptical and spherical end caps can also be used. We have not modelled and ‘bosses’ on the end caps for filling points. We just need to control the size of the winding ‘end openings’ to suit the actual boss condition. We well assume we have a boss diameter of 50mm at the LH end and 70mm at the RH end. Before starting some planning is required as we may end up creating several files and it makes things easier to have a logical naming system. In the previous page in the winding sequence we have suggested names for the separate program component. The vessel is designated V120 and the parts are V120xyy where x is H,T,P (Hoop, Transition, Polar – low angle) and yy is the position in the winding sequence i.e. 01,02,03

Mandrel Geometry

Layer 01 – Hoop winding

The first layer is a double hoop layer that will wrap from Position A to B and then back to A ( or B > A > B). As the next full layer is a low angle polar wind that will start at position C, in this instance the transition path is likely to be better from A to C, directly from B to C would always slip.

1] From The QuickCAD menu select the multi-hoop option. Please note that there are different Cadfil options and packages and some of the screen shots my have menu options that are not available on your system.

2] Click ‘No’ when prompted to ‘Load Existing data’ as we have no data to modify at the moment.

3] The Multi-hoop input dialog as shown to the left will be displayed. This is a data input form. The help button can be clicked to give context sensitive help. Any line of data can be clicked to pop a input/edit box. The top line is the radius (diameter/2) of the cylinder (155mm in this example). The clearance radius is 205mm thus the machine payout will be 205-155=50mm clearance from the surface of the cylinder. The fibre band width is 20mm, angular point spacing is set by default to 12 degrees and does not need to be changed (see help file). The number of X position is set to three which will be clearer later.

4] Referring to the diagram on the previous page position A is +270 mm from the origin (centre of the cylinder) and is our starting position. However we program the centre of the fibre band so we must adjust by of the bandwidth (10mm) and also we do not want the edge of the band to slip down the end cap so we must adjust away from the dome a little say 5mm. Thus the start position is 270-10-5=255mm. At this start position we have the option from some rotation without carriage movement (dwell) and we have specified 360 degree. Position B(X position 2) is at -255mm from the origin.

5] We will thus wind at hoop with a helical lead of one bandwidth per mandrel rotation from position 1 to position 2. We add 360 of dwell at position 2. 6] X position 3 is set to at +255mm from the origin, thus we hoop wind from position 2 to position 3. As we have set 3 ‘X positions’ we must set this at line 6 in the dialog.

7] The last step is to click ‘OK’ to exit.

8] Click ‘Yes’ to the prompt to save the Multi-Hoop Parameter Data.

9] At the ‘save as’ dialog (right) enter a name for the parameter file. Enter the planned file name, V120H01.par and click the ‘save’ button.

10] Click ‘OK’ to clear the ‘NC Post-Process’ message, we will do this step later.

11] From the ‘Payout View Menu’ select ‘View Options’ (top picture).

12] The Views Dialog (step11, middle picture) will then be displayed. From the ‘What to display’ pull down menu, pick ‘option 10 Fibre Bands’ and then click the draw button (see the red circled on picture).

13] The band structure on the cylinder will be displayed (see picture below).

14] Click the ‘exit’ button on the dialog and then from the ‘Payout View Menu’ select ‘Finish Viewing’ to exit from payout path viewing (step11, bottom picture).

Layer 03 – Helical winding

15] Referring back to our winding sequence on the first page of this tutorial we have now made a double hoop layer, the next step is the joining (transition) path to the low angle helical layer. However it makes more sense to generate the helical layer first so that we know what we are joining!

16] The designers specified a wind angle of 15 degrees on the cylinder. If we consider the geodesics path (shortest path for non-slip) the end-cap opening are radius is fixed at 155xSin(15)=40.1mm (155 being the radius of the cylinder).

17] If you do not have a calculator to hand this geodesic calculation can also be made using ‘Useful Calculations’ option the ‘Utilities’ Menu. If you enter radius 1 & angle 1 as 155 & 15 then at the turning point angle 2 =90 and thus radius 2 is given by clicking the calculate button. It must be remembered that this ‘opening radius’ is for the centre of the fibre band and the actual radius of the opening is reduced by half the band width.

18] Now Pick the ‘Vessel With End-caps’ option from the ‘QuickCAD’ Menu. The Mandrel geometry for this vessel is defined by the data parameters in the left hand red circle area in the picture below. You might wish to reffer back to the mandrel diagram at the start of this topic.

19] The clearance parameters for the winding machine C1=50, C2=90, SL=35, SR=35, shown in the right hand red circle area above. A full description of the Machine envelope (clearance) can be found by clicking the help button.

20] For an initial trial we will have a wind angle on the cylinder of 15 degrees, band width of 20mm and will have geodesic winding (non-geodesic box is not ticked) as in the circles area below.

21] Clicking the calculate button starts the path calculation. The next step is to pick a band-pattern to complete the path generation. The band pattern dialog is shown below.

22] Band pattern is discussed at length in the help file, which can be accessed directly from the help button. For this example click the top line, Option 1 to have a band pattern of 14 and then click ‘OK’

23] Clear the Dialog by clicking the ‘exit’ button. We can then review the data in the ‘Cadfil Text Window’.

24] Looking in the text information window (left) we can see that for a 15 degree wind angle the left hand end (LH) opening has a radius of 30mm if we consider the band edge and 40mm if we consider the centre of the band. Because this is geodesic winding the opening is the same at both ends and is fixed by the 15 degree wind angle.

25] Using the Views option (as at steps 11-14) the winding can be viewed, as illustrated on the next picture. The Left End Opening is R30 (60), the Right End View Opening is R30 (60)and the “Band Pattern is 14”.

26] We will now remake this program with non-geodesic winding. We will assume we want to close the winding to a 50 at the LH end cap 70 at the RH end. As we program the band centre opening radius we will thus need 35mm and 45mm at LH and RH ends, this allows an adjustment of 10mm (half a band width) for each value.

27] Pick the ‘Vessel With End-caps’ option from the ‘QuickCAD’ Menu. Click the ‘open’ box and then select the file V120P03.PAR we saved earlier. Note we tick the non-geodesic box and specify the end radius values. 35mm for the LH end and 45mm for the RH end as shown below.

28] Click the save button to re-save the V120P03.par file with the new data. On clicking the Calculate button the path is created and we can see we have the new end openings values and that the path is well within the friction limits for not slipping. The winding can be seen on the next picture. The LH End View Opening is R25 (50), the RH End ViewOpening is R30 (60) and the band pattern is 17 (15 degree wind angle).

29] Exiting from the payout viewing options, the next step is to start a combined winding. This is file that defines a sequence of programs that make a complete multi-layer program.

30] From the ‘NC Post-Process’ Menu pick the ‘Combine Programs’ Option. The ‘Edit/Modify combined Winding’ Dialog will pop up.

31] Normally we could pick the ‘Open’ option to retrieve a list that has been previously made however we are starting with a blank sheet so we pick the ‘add’ button. The add button opens a file browser dialog that will allow us to select payout (.PAY) files. Pick to Open the file V120H01.PAY for the hoop program.

32] You will be prompted for the number of times to repeat the program, click OK for the default value of 1 (left picture below). The second prompt (right picture below) is the item no. for the list. The default will be to add at the end of the list but we can use this feature to insert a program into the list at another location. Select OK for the default which is to append the program.

33] Repeat ‘ADD’ for the fileV120P03.PAY for the low angle program.

34] The dialog should now look like the picture above. Data for each for each program file is summarised here. The key information we need for the joining path is the end X position for the hoop program (x=255.0) and the start position for the low angle program (X=-374.3). Also note the mandrel file for the low angle program (V120P03.mnd) as we will use this also.

35] Click the ‘Finish’ button and then you will be prompted to save the combined program, save with the name V120.CTL as shown in the picture above.

Layer 02 – Joining Path

36] We now create the Joining path. From the ‘Main Options’ Menu Pick the ‘Create Joining Path’ (above) and then pick the mandrel for the complete vessel, V120P03.mnd (below)

37] The Mesh parameter (Number of elements/rev) is shown (below), accept the default value (60) clicking ‘OK’.

38] The next step (below) is to pick the start position, there are different modes of selection we will pick ‘Enter X position’ which then pops a dialog box . We enter the X start position of 255.0 to match the position of the end of the hoop-winding.

39] All Cadfil programs start and finish with the wind angle at 90 degrees (hoop) so at the next dialog (below) we pick Hoop up (+90 degrees).

40] As we are at 90 wind angle and are on a cylinder the geodesic would just circle around the mandrel with no axial movement. We need to apply friction to deviate the wind angle and steer the path to the desired location on the LH end cap where the low angle wind starts.

41] From the ‘Fibre Create’ menu pick the ‘Friction step option’ OR left mouse click on the ‘Cadfil Text Window’. Both will pop the step friction menu shown.

42] Click the ‘LH friction’ to set left hand deviation and set the friction % to 20%, and then click OK to close the dialog.

43] Left mouse click repeatedly on the Cadfil Graphics window and you will see the path advance to the left. You will notice in the text window that the winding angle decreases with each step. The path is advanced to X = -270 as shown to the right. You can note that the wind angle is 41 degrees but given the path we are wanting to join to has 15 degrees at this point there is a lot of difference. To speed things click on the text winding to pop the friction dialog and set the delete/create step to 10 by clicking the + or – box. A further 4 clicks on the graphics window will see the path advance passed the turning position as can be seen on the next page.

44] From the ‘Fibre Create’ menu select the ‘Test Hoop Pts’ option. In the picture below the results from the text window can be seen. The turning point X positions and radii (band centre) can be seen. The 2nd turning point has a large deviation from the start position of the low angle wind.
To achieve the desired turning position a much higher deviation would be required. To achieve a very stable transition path rather than the circuit of the mandrel we have made, making 1 circuits might be much better.

45] From the Fibre Path menu pick the ‘Restart Path’ option and then select no when asked if you want to save the path.

46] As before pick ‘Enter X Position’, set 255 as the start position and then Pick ‘Hoop Up’.

47] From the friction menu set Left Hand friction 10%, and step to 10.

48] After 11 clicks (position No 111 in the text window) you will note we have passed the turning point on the LH dome. We now need to reverse the friction from LH to RH.

49] After a further 8 clicks we are at position 191 and we have turned on the RH end cap as can be seen on the next page.

50] We now have 4 turning positions as shown. If we use the ‘Test Hoop Pts’ Options again we can see that the last turning point (4) is at X=-376, R=18 which is close to our target position. If we needed to improve we could right click on the graphics window a click or two to delete some path. Adjust the friction a little and then left click to re-generate a revised path. In this instance we do not need to do this.

51] From the Menu pick the ‘Finish and Save’ Option and save the path as V120T02.fib and then Click ‘Yes’ to create the payout path, and save as V120T02.pay.

52] We are now in the payout viewing options from which we should exit.

53] The last step is to Pick the ‘Combine Programs’ Option from the NC Post-Process menu.

54] Click the open button and open the V120.CTL file we created earlier.

55] We then ‘add’ the transition file V120T02.pay at position 2. The display should then look as the picture below.

56] Finally click ‘finish’ and save the combined file V120.ctl.

57] The last step will be to Pick 4 axis post-process from the NC-Post Process menu and pick the V120.CTL file to post-process with V120.prg as the output NC file. There are a number of post-processor configuration specific options which are described in the help file and finally we have the completed NC data for winding the CNG tank.